diff options
Diffstat (limited to 'flake.nix')
-rw-r--r-- | flake.nix | 44 |
1 files changed, 3 insertions, 41 deletions
@@ -25,17 +25,8 @@ default = pkgs.mkShell { name = "dev"; - buildInputs = with pkgs; [ - jq - highs - cjson - uthash - nix-eval-jobs - - pkg-config - meson - ninja - + inputsFrom = [ self.packages.${system}.evanix ]; + packages = with pkgs; [ gdb ccls valgrind @@ -55,36 +46,7 @@ { system, pkgs }: { default = self.packages.${system}.evanix; - evanix = pkgs.stdenv.mkDerivation (finalAttrs: { - name = "evanix"; - - src = ./.; - nativeBuildInputs = with pkgs; [ - uthash - meson - ninja - pkg-config - makeWrapper - ]; - buildInputs = with pkgs; [ - cjson - highs - ]; - - mesonFlags = [ - (lib.mesonOption "NIX_EVAL_JOBS_PATH" (lib.getExe pkgs.nix-eval-jobs)) - ]; - - meta = { - homepage = "https://git.sinanmohd.com/evanix"; - - license = lib.licenses.gpl3; - platforms = supportedSystems; - mainProgram = "evanix"; - - maintainers = with lib.maintainers; [ sinanmohd ]; - }; - }); + evanix = pkgs.callPackage ./package.nix { }; evanix-py = pkgs.python3Packages.callPackage ./python-package.nix { }; pythonWithEvanix = |