summaryrefslogtreecommitdiff
path: root/configuration.nix
diff options
context:
space:
mode:
authorsinanmohd <sinan@sinanmohd.com>2023-09-01 22:59:32 +0530
committersinanmohd <sinan@sinanmohd.com>2023-09-02 09:25:51 +0530
commit06d4452b1d18fd60b0f6adae50992418053f3971 (patch)
treefef36f1b8286730790dbfe2457fcd51c26e7bb81 /configuration.nix
parent444e2a8fb85d61e3768ae7f0ea07f2a79f69b775 (diff)
repo: clean up, rearrange packages
Diffstat (limited to 'configuration.nix')
-rw-r--r--configuration.nix17
1 files changed, 4 insertions, 13 deletions
diff --git a/configuration.nix b/configuration.nix
index fdac68a..f128856 100644
--- a/configuration.nix
+++ b/configuration.nix
@@ -1,7 +1,7 @@
-{ pkgs, lib, ... }:
+{ config, pkgs, lib, ... }:
let
- user = "sinan";
+ user = config.passthru.user;
in
{
imports = [
@@ -9,6 +9,8 @@ in
./hosts/cez.nix
];
+ passthru.user = "sinan";
+
# boot
boot = {
tmp.useTmpfs = true;
@@ -35,16 +37,8 @@ in
geoipWithDatabase
dig
nnn
- shellcheck
ffmpeg
- gnumake
rtorrent
- nixos-option
- pass
- gcc
- lua
- luajit
- neofetch
ps_mem
brightnessctl
];
@@ -63,13 +57,10 @@ in
unzip
bc
file
- openssl
git
htop
curl
neovim
- wget
- tree
];
};
system.stateVersion = "23.05";