summaryrefslogtreecommitdiff
path: root/configuration.nix
diff options
context:
space:
mode:
authorsinanmohd <sinan@sinanmohd.com>2023-08-29 12:43:19 +0530
committersinanmohd <sinan@sinanmohd.com>2023-08-29 14:52:06 +0530
commitda034c3c23a7779006443f032f3909e86d23a0ee (patch)
tree535da10261b926c441ae72f768a53d359e239513 /configuration.nix
parent2295504252272605189c968d977644f04afa3355 (diff)
repo: clean up
Diffstat (limited to 'configuration.nix')
-rw-r--r--configuration.nix22
1 files changed, 8 insertions, 14 deletions
diff --git a/configuration.nix b/configuration.nix
index 922b034..512c5b2 100644
--- a/configuration.nix
+++ b/configuration.nix
@@ -1,4 +1,4 @@
-{ pkgs, options, ... }:
+{ pkgs, lib, ... }:
let
user = "sinan";
@@ -72,23 +72,17 @@ in
];
};
system.stateVersion = "23.05";
- services.dbus.implementation = "broker";
# nix
- nix = {
- settings.experimental-features = [
+ nix.settings.experimental-features = [
"nix-command"
"flakes"
- ];
- };
- nixpkgs.overlays = with builtins;
- if pathExists ./overlays then
- map
- (overlay: import ./overlays/${overlay})
- (attrNames (readDir ./overlays))
- else
- options.nixpkgs.overlays.default
- ;
+ ];
+ nixpkgs.overlays = with builtins; lib.mkIf (pathExists ./overlays) (
+ map
+ (overlay: import ./overlays/${overlay})
+ (attrNames (readDir ./overlays))
+ );
# programs
programs = {