summaryrefslogtreecommitdiff
path: root/features/kaysshfs.nix
diff options
context:
space:
mode:
authorsinanmohd <sinan@sinanmohd.com>2023-08-08 07:45:37 +0530
committersinanmohd <sinan@sinanmohd.com>2023-08-10 05:36:17 +0530
commitaae7f5b6e7fefc263ce9d0932b341cb010e9ccd3 (patch)
tree65874635a2848bb4a9f676fe296ee6e3a3d6b495 /features/kaysshfs.nix
parent4c093e4143ac53c6e1acd202eb6ae7b78f66d0d1 (diff)
clean up: inconsistent list style
Diffstat (limited to 'features/kaysshfs.nix')
-rw-r--r--features/kaysshfs.nix9
1 files changed, 5 insertions, 4 deletions
diff --git a/features/kaysshfs.nix b/features/kaysshfs.nix
index ec6a118..83cb68e 100644
--- a/features/kaysshfs.nix
+++ b/features/kaysshfs.nix
@@ -1,13 +1,14 @@
{ config, pkgs, ... }:
{
- system.fsPackages = [ pkgs.sshfs ];
+ system.fsPackages = with pkgs; [
+ sshfs
+ ];
fileSystems."/mnt/kay" = {
device = "sinansftp@sinanmohd.com:";
fsType = "sshfs";
- options =
- [ # Filesystem options
+ options = [
"allow_other" # for non-root access
"_netdev" # this is a network fs
"x-systemd.automount" # mount on demand
@@ -16,6 +17,6 @@
"reconnect" # handle connection drops
"ServerAliveInterval=15" # keep connections alive
"IdentityFile=/var/secrets/kaysftp-key"
- ];
+ ];
};
}