summaryrefslogtreecommitdiff
path: root/features/kaysshfs.nix
diff options
context:
space:
mode:
authorsinanmohd <pcmsinan@gmail.com>2023-07-04 23:02:19 +0530
committersinanmohd <pcmsinan@gmail.com>2023-07-04 23:02:39 +0530
commitcad02678e29621f05183a7f03f3bae32bb4b3aeb (patch)
treeab7b6646264dfc148b7ddbd350da7d30d201ccf1 /features/kaysshfs.nix
parent0bd6b528dfb3f14b8dc0a5478dcb362e310ac224 (diff)
features/sshfs: initial commit
Diffstat (limited to 'features/kaysshfs.nix')
-rw-r--r--features/kaysshfs.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/features/kaysshfs.nix b/features/kaysshfs.nix
new file mode 100644
index 0000000..ec6a118
--- /dev/null
+++ b/features/kaysshfs.nix
@@ -0,0 +1,21 @@
+{ config, pkgs, ... }:
+
+{
+ system.fsPackages = [ pkgs.sshfs ];
+
+ fileSystems."/mnt/kay" = {
+ device = "sinansftp@sinanmohd.com:";
+ fsType = "sshfs";
+ options =
+ [ # Filesystem options
+ "allow_other" # for non-root access
+ "_netdev" # this is a network fs
+ "x-systemd.automount" # mount on demand
+
+ # SSH options
+ "reconnect" # handle connection drops
+ "ServerAliveInterval=15" # keep connections alive
+ "IdentityFile=/var/secrets/kaysftp-key"
+ ];
+ };
+}