summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorsinanmohd <sinan@sinanmohd.com>2024-06-03 18:28:35 +0530
committersinanmohd <sinan@sinanmohd.com>2024-06-03 18:39:43 +0530
commit279ff6251173e161cc50d8ae03cb3cd2e90a61a4 (patch)
tree971260447397a872be4b051b55864b482acc4a57 /flake.nix
parent4311eaf183976752acdf5624ea68516cac6f0d94 (diff)
global: init
global contains shared data between home-manager and nixos modules. they're just structured data, it's doesn't contain any module functionally in the normal sense, an example is preferred monospace font or user's mail id `config.global.userdata.email`
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/flake.nix b/flake.nix
index f93be2e..f6d8161 100644
--- a/flake.nix
+++ b/flake.nix
@@ -26,7 +26,7 @@
nix.nixPath = [ "nixpkgs=${nixpkgs}" ];
}
- ./userdata.nix
+ ./global
./os/${host}/configuration.nix
sops-nix.nixosModules.sops
];
@@ -35,7 +35,7 @@
makeHome = useType: system: home-manager.lib.homeManagerConfiguration {
pkgs = nixpkgs.legacyPackages.${system};
modules = [
- ./userdata.nix
+ ./global
./home/${useType}/home.nix
];
};