summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorsinanmohd <sinan@sinanmohd.com>2023-09-03 09:48:03 +0530
committersinanmohd <sinan@sinanmohd.com>2023-09-03 23:13:02 +0530
commit28f11cc5c704b6901dc94551fb1504f0091bb69f (patch)
tree7bf55a4884b6d4eabd987be657434a1c32c50860 /flake.nix
parentc636397e6062b4d9471a4b5f4e9cf7d34a257131 (diff)
flake/sops-nix: init
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix21
1 files changed, 17 insertions, 4 deletions
diff --git a/flake.nix b/flake.nix
index 93713c0..3c47785 100644
--- a/flake.nix
+++ b/flake.nix
@@ -1,16 +1,29 @@
{
description = "reproducible nixos configuration with flakes";
- inputs.nixpkgs.url = "github:NixOs/nixpkgs/nixos-unstable";
- outputs = { self, nixpkgs }: {
+ inputs = {
+ nixpkgs.url = "github:NixOs/nixpkgs/nixos-unstable";
+ sops-nix = {
+ url = "github:Mic92/sops-nix";
+ inputs.nixpkgs.follows = "nixpkgs";
+ };
+ };
+
+ outputs = { self, nixpkgs, sops-nix }: {
nixosConfigurations = {
cez = nixpkgs.lib.nixosSystem {
system = "x86_64-linux";
- modules = [ ./hosts/cez/configuration.nix ];
+ modules = [
+ ./hosts/cez/configuration.nix
+ sops-nix.nixosModules.sops
+ ];
};
kay = nixpkgs.lib.nixosSystem {
system = "x86_64-linux";
- modules = [ ./hosts/kay/configuration.nix ];
+ modules = [
+ ./hosts/kay/configuration.nix
+ sops-nix.nixosModules.sops
+ ];
};
};
};