summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorsinanmohd <sinan@sinanmohd.com>2023-09-02 22:05:18 +0530
committersinanmohd <sinan@sinanmohd.com>2023-09-03 00:42:50 +0530
commitc636397e6062b4d9471a4b5f4e9cf7d34a257131 (patch)
tree71329d182a7652301e92b19deec3ca40a7ac913f /flake.nix
parent49b8ea0f6813fe197f81a532199b18e0ded424d7 (diff)
flake: init
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..93713c0
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,17 @@
+{
+ description = "reproducible nixos configuration with flakes";
+ inputs.nixpkgs.url = "github:NixOs/nixpkgs/nixos-unstable";
+
+ outputs = { self, nixpkgs }: {
+ nixosConfigurations = {
+ cez = nixpkgs.lib.nixosSystem {
+ system = "x86_64-linux";
+ modules = [ ./hosts/cez/configuration.nix ];
+ };
+ kay = nixpkgs.lib.nixosSystem {
+ system = "x86_64-linux";
+ modules = [ ./hosts/kay/configuration.nix ];
+ };
+ };
+ };
+}