summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorsinanmohd <sinan@sinanmohd.com>2024-03-08 10:50:28 +0530
committersinanmohd <sinan@sinanmohd.com>2024-03-08 10:52:52 +0530
commitcd942d253bda8f511fdb921ea29f69f382a9368e (patch)
tree2c7aac5f66e5b614ecdd0871df23432bae4dc6db /flake.nix
parent2abeb90fbff1d33aadfec37ce80a6bc4d3551661 (diff)
repo: restructure source tree
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix7
1 files changed, 5 insertions, 2 deletions
diff --git a/flake.nix b/flake.nix
index 2749aed..8c63e01 100644
--- a/flake.nix
+++ b/flake.nix
@@ -3,6 +3,7 @@
inputs = {
nixpkgs.url = "github:NixOs/nixpkgs/nixos-unstable";
+
sops-nix = {
url = "github:Mic92/sops-nix";
inputs.nixpkgs.follows = "nixpkgs";
@@ -16,7 +17,8 @@
inherit system;
modules = [
{ networking.hostName = host; }
- ./hosts/${host}/configuration.nix
+ ./nixos/${host}/configuration.nix
+
sops-nix.nixosModules.sops
];
};
@@ -26,6 +28,7 @@
);
in
{
- nixosConfigurations = makeX86 [ "cez" "kay" "lia" "fscusat" "dspace" ];
+ nixosConfigurations =
+ makeX86 [ "cez" "kay" "lia" "fscusat" "dspace" ];
};
}