summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorsinanmohd <sinan@sinanmohd.com>2024-06-03 20:50:58 +0530
committersinanmohd <sinan@sinanmohd.com>2024-06-03 21:25:00 +0530
commitd4f7650cd0735d1fe9173530cc31c24b65ed44ff (patch)
tree82086000936fed44120734ce2308207478d73954 /flake.nix
parent279ff6251173e161cc50d8ae03cb3cd2e90a61a4 (diff)
global/font: init
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix14
1 files changed, 8 insertions, 6 deletions
diff --git a/flake.nix b/flake.nix
index f6d8161..70153b4 100644
--- a/flake.nix
+++ b/flake.nix
@@ -26,18 +26,20 @@
nix.nixPath = [ "nixpkgs=${nixpkgs}" ];
}
- ./global
+ ./global/common
./os/${host}/configuration.nix
sops-nix.nixosModules.sops
- ];
+ ] ++ lib.optional (builtins.pathExists ./global/${host})
+ ./global/${host};
};
- makeHome = useType: system: home-manager.lib.homeManagerConfiguration {
+ makeHome = host: system: home-manager.lib.homeManagerConfiguration {
pkgs = nixpkgs.legacyPackages.${system};
modules = [
- ./global
- ./home/${useType}/home.nix
- ];
+ ./global/common
+ ./home/${host}/home.nix
+ ] ++ lib.optional (builtins.pathExists ./global/${host})
+ ./global/${host};
};
in
{