summaryrefslogtreecommitdiff
path: root/home/cez/modules/wayland.nix
diff options
context:
space:
mode:
authorsinanmohd <sinan@sinanmohd.com>2024-06-05 22:22:45 +0530
committersinanmohd <sinan@sinanmohd.com>2024-06-05 22:22:45 +0530
commit7437a37e9ae174033e336e5d29f435ec78df27e0 (patch)
tree6d2a22b17a23b1136649173ed5d487bcbbfdf4ae /home/cez/modules/wayland.nix
parent1368cff428c3eb2112afeb53f4756bfdddaff363 (diff)
home/wayland/pkgs/wayland-scripts/freezshot: init
Diffstat (limited to 'home/cez/modules/wayland.nix')
-rw-r--r--home/cez/modules/wayland.nix8
1 files changed, 8 insertions, 0 deletions
diff --git a/home/cez/modules/wayland.nix b/home/cez/modules/wayland.nix
new file mode 100644
index 0000000..4c9e0ac
--- /dev/null
+++ b/home/cez/modules/wayland.nix
@@ -0,0 +1,8 @@
+{ pkgs, ... }: let
+ wayland-scripts = pkgs.callPackage ../../wayland/pkgs/wayland-scripts {};
+ freezshot = "${wayland-scripts}/bin/freezshot";
+in {
+ # vendor hardcoded screenshot key
+ wayland.windowManager.sway.settings.bindsym."mod4+shift+s" =
+ "exec ${freezshot}";
+}