summaryrefslogtreecommitdiff
path: root/home/common/home.nix
diff options
context:
space:
mode:
authorsinanmohd <sinan@sinanmohd.com>2024-06-03 18:28:35 +0530
committersinanmohd <sinan@sinanmohd.com>2024-06-03 18:39:43 +0530
commit279ff6251173e161cc50d8ae03cb3cd2e90a61a4 (patch)
tree971260447397a872be4b051b55864b482acc4a57 /home/common/home.nix
parent4311eaf183976752acdf5624ea68516cac6f0d94 (diff)
global: init
global contains shared data between home-manager and nixos modules. they're just structured data, it's doesn't contain any module functionally in the normal sense, an example is preferred monospace font or user's mail id `config.global.userdata.email`
Diffstat (limited to 'home/common/home.nix')
-rw-r--r--home/common/home.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/home/common/home.nix b/home/common/home.nix
index 4ee0d94..b2ca191 100644
--- a/home/common/home.nix
+++ b/home/common/home.nix
@@ -1,5 +1,5 @@
{ config, ... }: let
- username = config.userdata.name;
+ username = config.global.userdata.name;
in {
imports = [
./modules/git.nix