summaryrefslogtreecommitdiff
path: root/home/common/modules/git.nix
diff options
context:
space:
mode:
authorsinanmohd <sinan@sinanmohd.com>2024-04-30 21:23:53 +0530
committersinanmohd <sinan@sinanmohd.com>2024-04-30 21:23:53 +0530
commit3fc51de5171feb362b8373273c3e82de2a70e076 (patch)
treeeb3117b25593dd9b13c67bdd36a7c57407130c96 /home/common/modules/git.nix
parent2489ed494af18c22d7cd100f4fbbe7ca9a659f6e (diff)
home: home-manager -> home
Diffstat (limited to 'home/common/modules/git.nix')
-rw-r--r--home/common/modules/git.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/home/common/modules/git.nix b/home/common/modules/git.nix
new file mode 100644
index 0000000..7337f7b
--- /dev/null
+++ b/home/common/modules/git.nix
@@ -0,0 +1,15 @@
+{ config, ... }: let
+ userName = config.userdata.nameFq;
+ userEmail = config.userdata.email;
+in {
+ programs.git = {
+ enable = true;
+ inherit userName;
+ inherit userEmail;
+
+ extraConfig = {
+ color.ui = "auto";
+ init.defaultBranch = "master";
+ };
+ };
+}