summaryrefslogtreecommitdiff
path: root/home/common/modules/xdgdirs.nix
diff options
context:
space:
mode:
authorsinanmohd <sinan@sinanmohd.com>2024-06-18 08:15:36 +0530
committersinanmohd <sinan@sinanmohd.com>2024-06-18 08:20:18 +0530
commite188c7ad2688d07a1494ec6f87c6e8d854dd63b1 (patch)
tree2b34cd17f4bcc2d1e81547380b03d78fa27adbe8 /home/common/modules/xdgdirs.nix
parent0291edd8873549027648faef2579ea3f1ca8a07d (diff)
home/common/xdgdirs: init
Diffstat (limited to 'home/common/modules/xdgdirs.nix')
-rw-r--r--home/common/modules/xdgdirs.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/home/common/modules/xdgdirs.nix b/home/common/modules/xdgdirs.nix
new file mode 100644
index 0000000..3073a10
--- /dev/null
+++ b/home/common/modules/xdgdirs.nix
@@ -0,0 +1,23 @@
+{ config, ... }: let
+ home = config.home.homeDirectory;
+
+ etc = home + "/etc";
+ dl = home + "/dl";
+in {
+ xdg = {
+ enable = true;
+
+ userDirs = {
+ enable = true;
+
+ download = dl;
+ desktop = etc;
+ templates = etc;
+ publicShare = dl;
+ music = home + "/ms";
+ videos = home + "/vid";
+ pictures = home + "/pix";
+ documents = home + "/doc";
+ };
+ };
+}