summaryrefslogtreecommitdiff
path: root/home/pc/modules/pass.nix
diff options
context:
space:
mode:
authorsinanmohd <sinan@sinanmohd.com>2024-06-04 14:38:25 +0530
committersinanmohd <sinan@sinanmohd.com>2024-06-04 18:04:18 +0530
commit654fa9e430be421df30ee79e7ea5f4e40b39dddc (patch)
tree37d9bc759e3e1b3323e76d85d706123f3b799d88 /home/pc/modules/pass.nix
parent84073038e22d3201ac0176a94527c040bb153e9e (diff)
home, os: refactor
Diffstat (limited to 'home/pc/modules/pass.nix')
-rw-r--r--home/pc/modules/pass.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/home/pc/modules/pass.nix b/home/pc/modules/pass.nix
new file mode 100644
index 0000000..9117c3a
--- /dev/null
+++ b/home/pc/modules/pass.nix
@@ -0,0 +1,10 @@
+{ pkgs, ... }: {
+ home.packages = with pkgs; [
+ (pass.withExtensions (exts: [ exts.pass-otp ]))
+ ];
+
+ services.gpg-agent = {
+ enable = true;
+ pinentryPackage = pkgs.pinentry-bemenu;
+ };
+}