summaryrefslogtreecommitdiff
path: root/home/wayland/modules/sway/bemenu.nix
diff options
context:
space:
mode:
authorsinanmohd <sinan@sinanmohd.com>2024-06-18 09:34:09 +0530
committersinanmohd <sinan@sinanmohd.com>2024-06-18 11:24:18 +0530
commit6e965e855e752e01adb78f7e2492351aa7ce88c7 (patch)
tree3c5095ea2e5ff8fda92571d4241adc415f867c21 /home/wayland/modules/sway/bemenu.nix
parente188c7ad2688d07a1494ec6f87c6e8d854dd63b1 (diff)
home/wayland/bemenu: init
Diffstat (limited to 'home/wayland/modules/sway/bemenu.nix')
-rw-r--r--home/wayland/modules/sway/bemenu.nix31
1 files changed, 31 insertions, 0 deletions
diff --git a/home/wayland/modules/sway/bemenu.nix b/home/wayland/modules/sway/bemenu.nix
new file mode 100644
index 0000000..ced6b2f
--- /dev/null
+++ b/home/wayland/modules/sway/bemenu.nix
@@ -0,0 +1,31 @@
+{ config, lib, ... }: let
+ background = "#000000";
+ foreground = "#FFFFFF";
+ swayYellow = "#d79921";
+
+ font = config.global.font.sans.name
+ + lib.optionalString (config.global.font.sans.size != null)
+ " " + builtins.toString config.global.font.sans.size;
+in {
+ programs.bemenu = {
+ enable = true;
+
+ settings = {
+ fn = font;
+ hp = 6;
+
+ tf = swayYellow;
+ hf = swayYellow;
+
+ nf = foreground;
+ af = foreground;
+
+ nb = background;
+ cf = background;
+ tb = background;
+ fb = background;
+ hb = background;
+ ab = background;
+ };
+ };
+}