summaryrefslogtreecommitdiff
path: root/home/wayland/modules/zathura.nix
diff options
context:
space:
mode:
authorsinanmohd <sinan@sinanmohd.com>2024-06-08 06:15:39 +0530
committersinanmohd <sinan@sinanmohd.com>2024-06-08 07:10:59 +0530
commit92c8ab73bf974457ea1dc720b3fe6876496294c4 (patch)
tree907bd411605ff6c793a41ec442eacc3de5b8ca5a /home/wayland/modules/zathura.nix
parentc82ff3c17a1787be9348c3939284c57093da8b2f (diff)
home/wayland/sway: properly use `global.font`
Diffstat (limited to 'home/wayland/modules/zathura.nix')
-rw-r--r--home/wayland/modules/zathura.nix3
1 files changed, 1 insertions, 2 deletions
diff --git a/home/wayland/modules/zathura.nix b/home/wayland/modules/zathura.nix
index 9a013da..faec245 100644
--- a/home/wayland/modules/zathura.nix
+++ b/home/wayland/modules/zathura.nix
@@ -1,8 +1,7 @@
{ config, lib, ... }: let
font = config.global.font.sans.name
- + " "
+ lib.optionalString (config.global.font.sans.size != null)
- (builtins.toString config.global.font.sans.size);
+ " " + builtins.toString config.global.font.sans.size;
in {
programs.zathura = {
enable = true;