summaryrefslogtreecommitdiff
path: root/hosts/cez/modules/wayland.nix
diff options
context:
space:
mode:
authorsinanmohd <sinan@sinanmohd.com>2023-11-04 16:00:49 +0530
committersinanmohd <sinan@sinanmohd.com>2023-11-05 21:11:49 +0530
commit493c355153cb690d87d99303e4a550bf16e8d747 (patch)
tree7607133244ec8287469d15cdaa8fe61f47f1152f /hosts/cez/modules/wayland.nix
parent8214a997e1d8fac0fdf238d0d889f6c3a22b48e6 (diff)
cez/wayland: dwl -> sway
Diffstat (limited to 'hosts/cez/modules/wayland.nix')
-rw-r--r--hosts/cez/modules/wayland.nix19
1 files changed, 8 insertions, 11 deletions
diff --git a/hosts/cez/modules/wayland.nix b/hosts/cez/modules/wayland.nix
index 524b1fc..69e738a 100644
--- a/hosts/cez/modules/wayland.nix
+++ b/hosts/cez/modules/wayland.nix
@@ -1,4 +1,4 @@
-{ config, pkgs, ... }:
+{ config, pkgs, lib, ... }:
let
user = config.userdata.user;
@@ -6,32 +6,30 @@ in
{
# pkgs
environment.systemPackages = with pkgs; [
- dwl-sinan
- wmenu
- pinentry-gnome
+ bemenu
+ sway
+ i3status
+ pinentry-bemenu
swaylock
swayidle
swaybg
foot
wl-clipboard
mako
- wayland
xdg-utils
libnotify
- wob
- wlr-randr
];
users.users.${user}.packages = with pkgs; [
zathura
mpv
imv
wtype
- tor-browser-bundle-bin
qemu
OVMFFull
- element-desktop-wayland
grim
slurp
+ tor-browser-bundle-bin
+ element-desktop-wayland
];
# font
@@ -61,10 +59,9 @@ in
};
programs = {
- xwayland.enable = true;
gnupg.agent = {
enable = true;
- pinentryFlavor = "gnome3";
+ settings.pinentry-program = lib.mkForce "${pkgs.pinentry-bemenu}/bin/pinentry-bemenu";
};
firefox = {
enable = true;