summaryrefslogtreecommitdiff
path: root/hosts/cez/modules/wayland.nix
diff options
context:
space:
mode:
authorsinanmohd <sinan@sinanmohd.com>2024-03-08 10:50:28 +0530
committersinanmohd <sinan@sinanmohd.com>2024-03-08 10:52:52 +0530
commitcd942d253bda8f511fdb921ea29f69f382a9368e (patch)
tree2c7aac5f66e5b614ecdd0871df23432bae4dc6db /hosts/cez/modules/wayland.nix
parent2abeb90fbff1d33aadfec37ce80a6bc4d3551661 (diff)
repo: restructure source tree
Diffstat (limited to 'hosts/cez/modules/wayland.nix')
-rw-r--r--hosts/cez/modules/wayland.nix83
1 files changed, 0 insertions, 83 deletions
diff --git a/hosts/cez/modules/wayland.nix b/hosts/cez/modules/wayland.nix
deleted file mode 100644
index c04d1bf..0000000
--- a/hosts/cez/modules/wayland.nix
+++ /dev/null
@@ -1,83 +0,0 @@
-{ config, pkgs, lib, ... }:
-
-let
- user = config.userdata.user;
-in
-{
- # pkgs
- environment.systemPackages = with pkgs; [
- bemenu
- sway
- i3status
- swaylock
- swayidle
- swaybg
- foot
- wl-clipboard
- mako
- xdg-utils
- libnotify
- ];
-
- users.users.${user} = {
- extraGroups = [ "seat" ];
- packages = with pkgs; [
- zathura
- mpv
- imv
- wtype
- qemu
- OVMFFull
- grim
- slurp
- tor-browser-bundle-bin
- element-desktop-wayland
- pinentry-bemenu
- ];
- };
-
- # font
- fonts = {
- packages = with pkgs; [
- terminus-nerdfont
- dm-sans
- ];
- enableDefaultPackages = true;
- fontconfig = {
- hinting.style = "full";
- subpixel.rgba = "rgb";
- defaultFonts = {
- monospace = [ "Terminess Nerd Font" ];
- serif = [ "DeepMind Sans" ];
- sansSerif = [ "DeepMind Sans" ];
- };
- };
- };
-
- # misc
- services = {
- seatd.enable = true;
- dbus = {
- implementation = "broker";
- enable = true;
- };
- };
-
- programs = {
- gnupg.agent = {
- enable = true;
- settings.pinentry-program = lib.mkForce "${pkgs.pinentry-bemenu}/bin/pinentry-bemenu";
- };
- firefox = {
- enable = true;
- preferences = {
- "media.ffmpeg.vaapi.enabled" = true;
- "gfx.webrender.all" = true;
- "identity.fxaccounts.enabled" = false;
- };
- };
- };
-
- security.pam.services.swaylock.text = "auth include login";
- hardware.opengl.enable = true;
-}