summaryrefslogtreecommitdiff
path: root/hosts/common.nix
diff options
context:
space:
mode:
authorsinanmohd <sinan@sinanmohd.com>2023-09-03 09:48:03 +0530
committersinanmohd <sinan@sinanmohd.com>2023-09-03 23:13:02 +0530
commit28f11cc5c704b6901dc94551fb1504f0091bb69f (patch)
tree7bf55a4884b6d4eabd987be657434a1c32c50860 /hosts/common.nix
parentc636397e6062b4d9471a4b5f4e9cf7d34a257131 (diff)
flake/sops-nix: init
Diffstat (limited to 'hosts/common.nix')
-rw-r--r--hosts/common.nix9
1 files changed, 9 insertions, 0 deletions
diff --git a/hosts/common.nix b/hosts/common.nix
index 56f2953..8cc13d8 100644
--- a/hosts/common.nix
+++ b/hosts/common.nix
@@ -3,6 +3,7 @@
let
user = config.userdata.user;
groups = config.userdata.groups;
+ host = config.networking.hostName;
in
{
imports = [
@@ -61,6 +62,8 @@ in
htop
curl
neovim
+ age
+ sops
];
};
system.stateVersion = "23.05";
@@ -72,6 +75,12 @@ in
];
nixpkgs.overlays = (import ../overlays);
+ # sops
+ sops = {
+ defaultSopsFile = "./${host}/secrets.yaml";
+ age.keyFile = "/var/secrets/sops-nix/key.txt";
+ };
+
# programs
programs = {
adb.enable = true;