summaryrefslogtreecommitdiff
path: root/hosts/common.nix
diff options
context:
space:
mode:
authorsinanmohd <sinan@sinanmohd.com>2023-09-06 18:48:34 +0530
committersinanmohd <sinan@sinanmohd.com>2023-09-06 19:02:57 +0530
commit4972c53e861752d9b3ca29a58c71db84973c9ab5 (patch)
tree046098e07e3570a2107ff3ef979a0b74d837ea0a /hosts/common.nix
parent28f11cc5c704b6901dc94551fb1504f0091bb69f (diff)
repo: restructuring
Diffstat (limited to 'hosts/common.nix')
-rw-r--r--hosts/common.nix95
1 files changed, 0 insertions, 95 deletions
diff --git a/hosts/common.nix b/hosts/common.nix
deleted file mode 100644
index 8cc13d8..0000000
--- a/hosts/common.nix
+++ /dev/null
@@ -1,95 +0,0 @@
-{ config, pkgs, lib, ... }:
-
-let
- user = config.userdata.user;
- groups = config.userdata.groups;
- host = config.networking.hostName;
-in
-{
- imports = [
- ../modules/userdata.nix
- ../modules/dev.nix
- ];
-
- # boot
- boot = {
- tmp.useTmpfs = true;
- loader = {
- timeout = 1;
- systemd-boot.enable = true;
- efi.canTouchEfiVariables = true;
- };
- };
-
- # networking
- time.timeZone = "Asia/Kolkata";
- networking.useDHCP = lib.mkDefault true;
-
- # users
- users.users.${user} = {
- isNormalUser = true;
- extraGroups = [
- "wheel"
- "adbusers"
- ] ++ groups;
- packages = with pkgs; [
- pass
- yt-dlp
- geoipWithDatabase
- dig
- nnn
- ffmpeg
- rtorrent
- ps_mem
- brightnessctl
- neofetch
- ];
- };
-
- # system
- environment = {
- binsh = "${pkgs.dash}/bin/dash";
- shellAliases = {
- ls = "ls --color=auto --group-directories-first";
- grep = "grep --color=auto";
- };
- systemPackages = with pkgs; [
- dash
- unzip
- bc
- file
- git
- htop
- curl
- neovim
- age
- sops
- ];
- };
- system.stateVersion = "23.05";
-
- # nix
- nix.settings.experimental-features = [
- "flakes"
- "nix-command"
- ];
- nixpkgs.overlays = (import ../overlays);
-
- # sops
- sops = {
- defaultSopsFile = "./${host}/secrets.yaml";
- age.keyFile = "/var/secrets/sops-nix/key.txt";
- };
-
- # programs
- programs = {
- adb.enable = true;
- bash.promptInit = ''
- PROMPT_COLOR="1;31m"
- [ "$UID" -ne 0 ] &&
- PROMPT_COLOR="1;32m"
-
- PS1="\[\033[$PROMPT_COLOR\][\[\e]0;\u@\h: \w\a\]\u@\h:\w]\\$\[\033[0m\] "
- '';
- };
-}