summaryrefslogtreecommitdiff
path: root/hosts/dspace/hardware-configuration.nix
diff options
context:
space:
mode:
authorsinanmohd <sinan@sinanmohd.com>2024-01-09 11:51:51 +0530
committersinanmohd <sinan@sinanmohd.com>2024-01-09 12:03:25 +0530
commitca76ec99a638fb7ef8f54644695a47b627d64257 (patch)
treea5bcb5d8f3e5889890112a9dd68d6a4e9432cf8a /hosts/dspace/hardware-configuration.nix
parent9cc1ae1d48b23ec8211d3875e61ce5d1ea5e9f6c (diff)
hosts/dspace: init
Diffstat (limited to 'hosts/dspace/hardware-configuration.nix')
-rw-r--r--hosts/dspace/hardware-configuration.nix27
1 files changed, 27 insertions, 0 deletions
diff --git a/hosts/dspace/hardware-configuration.nix b/hosts/dspace/hardware-configuration.nix
new file mode 100644
index 0000000..c355e8b
--- /dev/null
+++ b/hosts/dspace/hardware-configuration.nix
@@ -0,0 +1,27 @@
+{ lib, modulesPath, ... }:
+
+{
+ imports = [ (modulesPath + "/profiles/qemu-guest.nix") ];
+
+ boot.initrd.availableKernelModules = [
+ "ata_piix"
+ "uhci_hcd"
+ "virtio_pci"
+ "virtio_scsi"
+ "sd_mod"
+ "sr_mod"
+ ];
+
+ fileSystems = {
+ "/" = {
+ device = "/dev/disk/by-uuid/c5b1077e-52e8-4249-8bd7-d53eafa41f5a";
+ fsType = "ext4";
+ };
+ "/boot" = {
+ device = "/dev/disk/by-uuid/9787-FFFE";
+ fsType = "vfat";
+ };
+ };
+
+ nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
+}