summaryrefslogtreecommitdiff
path: root/hosts/fscusat/modules/network.nix
diff options
context:
space:
mode:
authorsinanmohd <sinan@sinanmohd.com>2024-01-09 11:50:12 +0530
committersinanmohd <sinan@sinanmohd.com>2024-01-09 11:50:12 +0530
commit9cc1ae1d48b23ec8211d3875e61ce5d1ea5e9f6c (patch)
treeedf9a156113a1c6add0954c60ab9818f8f2b03db /hosts/fscusat/modules/network.nix
parent1a8b7a406ab6d03730e2e0ac42691b02d55bef58 (diff)
hosts: mox -> fscusat
Diffstat (limited to 'hosts/fscusat/modules/network.nix')
-rw-r--r--hosts/fscusat/modules/network.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/hosts/fscusat/modules/network.nix b/hosts/fscusat/modules/network.nix
new file mode 100644
index 0000000..53367f8
--- /dev/null
+++ b/hosts/fscusat/modules/network.nix
@@ -0,0 +1,18 @@
+{ ... }:
+
+let
+ wan = "ens18";
+in
+{
+ networking = {
+ interfaces.${wan}.ipv4.addresses = [{
+ address = "10.0.8.101";
+ prefixLength = 16;
+ }];
+ defaultGateway = {
+ address = "10.0.0.1";
+ interface = wan;
+ };
+ nameservers = [ "10.0.0.2" "10.0.0.3" ];
+ };
+}