summaryrefslogtreecommitdiff
path: root/hosts/kay/hardware-configuration.nix
diff options
context:
space:
mode:
authorsinanmohd <sinan@sinanmohd.com>2023-09-02 22:05:18 +0530
committersinanmohd <sinan@sinanmohd.com>2023-09-03 00:42:50 +0530
commitc636397e6062b4d9471a4b5f4e9cf7d34a257131 (patch)
tree71329d182a7652301e92b19deec3ca40a7ac913f /hosts/kay/hardware-configuration.nix
parent49b8ea0f6813fe197f81a532199b18e0ded424d7 (diff)
flake: init
Diffstat (limited to 'hosts/kay/hardware-configuration.nix')
-rw-r--r--hosts/kay/hardware-configuration.nix32
1 files changed, 32 insertions, 0 deletions
diff --git a/hosts/kay/hardware-configuration.nix b/hosts/kay/hardware-configuration.nix
new file mode 100644
index 0000000..1583736
--- /dev/null
+++ b/hosts/kay/hardware-configuration.nix
@@ -0,0 +1,32 @@
+{ modulesPath, ... }:
+
+{
+ imports = [ (modulesPath + "/installer/scan/not-detected.nix") ];
+
+ boot = {
+ kernelModules = [ "kvm-intel" ];
+ initrd.availableKernelModules = [
+ "xhci_pci"
+ "ehci_pci"
+ "ahci"
+ "usb_storage"
+ "usbhid"
+ "sd_mod"
+ ];
+ };
+
+ fileSystems = {
+ "/" = {
+ device = "/dev/disk/by-uuid/2eeacf49-c51e-4229-bd4a-ae437014725f";
+ fsType = "ext4";
+ };
+ "/boot" = {
+ device = "/dev/disk/by-uuid/A902-90BB";
+ fsType = "vfat";
+ };
+ "/hdd" = {
+ device = "/dev/disk/by-uuid/c941edb4-e393-4254-bbef-d1b3728290e9";
+ fsType = "ext4";
+ };
+ };
+}