summaryrefslogtreecommitdiff
path: root/hosts/kay/modules/matrix-sliding-sync.nix
diff options
context:
space:
mode:
authorsinanmohd <sinan@sinanmohd.com>2023-12-24 07:22:21 +0530
committersinanmohd <sinan@sinanmohd.com>2023-12-27 08:14:06 +0530
commit565225847ebf54aa57722271dd83d99954a55076 (patch)
tree4b0bdeaff2907a783e3081ad2658a49c64ec5537 /hosts/kay/modules/matrix-sliding-sync.nix
parenta74e008263afe2a3a71a4cf5b76ca71e62ae3b21 (diff)
modules/matrix-sliding-sync: init dendrite
Diffstat (limited to 'hosts/kay/modules/matrix-sliding-sync.nix')
-rw-r--r--hosts/kay/modules/matrix-sliding-sync.nix14
1 files changed, 14 insertions, 0 deletions
diff --git a/hosts/kay/modules/matrix-sliding-sync.nix b/hosts/kay/modules/matrix-sliding-sync.nix
new file mode 100644
index 0000000..526734b
--- /dev/null
+++ b/hosts/kay/modules/matrix-sliding-sync.nix
@@ -0,0 +1,14 @@
+{ config, ... }:
+
+let
+ domain = config.userdata.domain;
+in
+{
+ sops.secrets."matrix-${domain}/sliding_sync" = {};
+
+ services.matrix-sliding-sync = {
+ enable = true;
+ environmentFile = config.sops.secrets."matrix-${domain}/sliding_sync".path;
+ settings.SYNCV3_SERVER = "https://${domain}";
+ };
+}