summaryrefslogtreecommitdiff
path: root/hosts/kay/modules/network.nix
diff options
context:
space:
mode:
authorsinanmohd <sinan@sinanmohd.com>2023-12-23 11:07:10 +0530
committersinanmohd <sinan@sinanmohd.com>2023-12-23 12:37:46 +0530
commitcb0606d7935d9c8cf35ce095c5c7b91a61fa683a (patch)
tree96e03520b0e41df1e8b66e8ba3098ef039baabd1 /hosts/kay/modules/network.nix
parent428cf4c0e22df10dd3df3a7ac926bc81e318c234 (diff)
kay/network: switch lan and wan port
Diffstat (limited to 'hosts/kay/modules/network.nix')
-rw-r--r--hosts/kay/modules/network.nix4
1 files changed, 3 insertions, 1 deletions
diff --git a/hosts/kay/modules/network.nix b/hosts/kay/modules/network.nix
index c31765b..0601815 100644
--- a/hosts/kay/modules/network.nix
+++ b/hosts/kay/modules/network.nix
@@ -2,7 +2,7 @@
let
inetVlan = 722;
- wanInterface = "enp4s0";
+ wanInterface = "enp0s20u1";
nameServer = "1.0.0.1";
domain = config.userdata.domain;
in
@@ -24,6 +24,8 @@ in
id = inetVlan;
interface = wanInterface;
};
+ # isp checks this macid during ppp authentication
+ interfaces.${wanInterface}.macAddress = "c4:54:44:d5:17:68";
};
services = {