summaryrefslogtreecommitdiff
path: root/hosts/kay/modules/router.nix
diff options
context:
space:
mode:
authorsinanmohd <sinan@sinanmohd.com>2023-12-23 11:07:10 +0530
committersinanmohd <sinan@sinanmohd.com>2023-12-23 12:37:46 +0530
commitcb0606d7935d9c8cf35ce095c5c7b91a61fa683a (patch)
tree96e03520b0e41df1e8b66e8ba3098ef039baabd1 /hosts/kay/modules/router.nix
parent428cf4c0e22df10dd3df3a7ac926bc81e318c234 (diff)
kay/network: switch lan and wan port
Diffstat (limited to 'hosts/kay/modules/router.nix')
-rw-r--r--hosts/kay/modules/router.nix8
1 files changed, 7 insertions, 1 deletions
diff --git a/hosts/kay/modules/router.nix b/hosts/kay/modules/router.nix
index cc9aaae..c621620 100644
--- a/hosts/kay/modules/router.nix
+++ b/hosts/kay/modules/router.nix
@@ -1,7 +1,7 @@
{ ... }:
let
- lanInterface = "enp0s20u1";
+ lanInterface = "enp4s0";
wanInterface = "ppp0";
subnet = "10.0.0.0";
prefix = 24;
@@ -24,6 +24,12 @@ in
address = host;
prefixLength = prefix;
}];
+ # the mac id of the built-in nic is required for
+ # ppp authentication with isp, this is here to avoid
+ # mac address collision since it's original mac id is used
+ # by the new wan interface for ppp authentication
+ # see ./network.nix
+ macAddress = "40:ed:00:08:ba:be";
};
firewall = {
allowedUDPPorts = [ 53 67 ];