summaryrefslogtreecommitdiff
path: root/hosts/kay/modules/router.nix
diff options
context:
space:
mode:
authorsinanmohd <sinan@sinanmohd.com>2024-03-08 10:50:28 +0530
committersinanmohd <sinan@sinanmohd.com>2024-03-08 10:52:52 +0530
commitcd942d253bda8f511fdb921ea29f69f382a9368e (patch)
tree2c7aac5f66e5b614ecdd0871df23432bae4dc6db /hosts/kay/modules/router.nix
parent2abeb90fbff1d33aadfec37ce80a6bc4d3551661 (diff)
repo: restructure source tree
Diffstat (limited to 'hosts/kay/modules/router.nix')
-rw-r--r--hosts/kay/modules/router.nix43
1 files changed, 0 insertions, 43 deletions
diff --git a/hosts/kay/modules/router.nix b/hosts/kay/modules/router.nix
deleted file mode 100644
index d2785a5..0000000
--- a/hosts/kay/modules/router.nix
+++ /dev/null
@@ -1,43 +0,0 @@
-{ ... }:
-
-let
- lanInterface = "enp0s20u4";
- wanInterface = "ppp0";
- subnet = "10.0.0.0";
- prefix = 24;
- host = "10.0.0.1";
- leaseRangeStart = "10.0.0.100";
- leaseRangeEnd = "10.0.0.254";
-in
-{
- imports = [
- ./wireguard.nix
- ./iperf3.nix
- ];
-
- networking = {
- nat = {
- enable = true;
- externalInterface = wanInterface;
- internalInterfaces = [ lanInterface ];
- };
- interfaces."${lanInterface}" = {
- ipv4.addresses = [{
- address = host;
- prefixLength = prefix;
- }];
- };
- firewall = {
- allowedUDPPorts = [ 53 67 ];
- allowedTCPPorts = [ 53 ];
- extraCommands = ''
- iptables -t nat -I POSTROUTING 1 -s ${subnet}/${toString prefix} -o ${wanInterface} -j MASQUERADE
- '';
- };
- };
-
- services.dnsmasq.settings = {
- dhcp-range = [ "${leaseRangeStart},${leaseRangeEnd}" ];
- interface = [ lanInterface ];
- };
-}