summaryrefslogtreecommitdiff
path: root/hosts/mox/configuration.nix
diff options
context:
space:
mode:
authorsinanmohd <sinan@sinanmohd.com>2023-11-13 17:31:53 +0530
committersinanmohd <sinan@sinanmohd.com>2023-11-13 18:08:54 +0530
commit8eb0bd9d2c2e39e5f07226d1a8e226514acd9c78 (patch)
treebb8f650236f457ec25c19d83fed8c7e24a57e248 /hosts/mox/configuration.nix
parentbc838a0c45ed6f6984c87eb6de9c075ad520f7d1 (diff)
hosts/mox: init
Diffstat (limited to 'hosts/mox/configuration.nix')
-rw-r--r--hosts/mox/configuration.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/hosts/mox/configuration.nix b/hosts/mox/configuration.nix
new file mode 100644
index 0000000..6742cc3
--- /dev/null
+++ b/hosts/mox/configuration.nix
@@ -0,0 +1,18 @@
+{ pkgs, ... }:
+
+{
+ imports = [
+ ./hardware-configuration.nix
+ ./modules/network.nix
+ ../../common.nix
+ ];
+
+ services.openssh = {
+ enable = true;
+ settings.PasswordAuthentication = false;
+ };
+
+ boot.consoleLogLevel = 3;
+ networking.hostName = "mox";
+ environment.systemPackages = with pkgs; [ tmux ];
+}