summaryrefslogtreecommitdiff
path: root/modules/userdata.nix
diff options
context:
space:
mode:
authorsinanmohd <sinan@sinanmohd.com>2024-03-08 10:50:28 +0530
committersinanmohd <sinan@sinanmohd.com>2024-03-08 10:52:52 +0530
commitcd942d253bda8f511fdb921ea29f69f382a9368e (patch)
tree2c7aac5f66e5b614ecdd0871df23432bae4dc6db /modules/userdata.nix
parent2abeb90fbff1d33aadfec37ce80a6bc4d3551661 (diff)
repo: restructure source tree
Diffstat (limited to 'modules/userdata.nix')
-rw-r--r--modules/userdata.nix31
1 files changed, 0 insertions, 31 deletions
diff --git a/modules/userdata.nix b/modules/userdata.nix
deleted file mode 100644
index 00f0e13..0000000
--- a/modules/userdata.nix
+++ /dev/null
@@ -1,31 +0,0 @@
-{ config, lib, ... }:
-
-let
- inherit (lib) mkOption types mdDoc;
- cfg = config.userdata;
-in
-{
- options.userdata = {
- user = mkOption {
- type = types.str;
- default = "sinan";
- description = mdDoc "Owner's username";
- };
- domain = mkOption {
- type = types.str;
- default = "sinanmohd.com";
- description = mdDoc "Owner's domain";
- };
- email = mkOption {
- type = types.str;
- default = "sinan@${cfg.domain}";
- description = mdDoc "Owner's email";
- };
- };
-
- config.users.users.${cfg.user} = {
- uid = 1000;
- isNormalUser = true;
- description = cfg.email;
- };
-}