summaryrefslogtreecommitdiff
path: root/modules/userdata.nix
diff options
context:
space:
mode:
authorsinanmohd <sinan@sinanmohd.com>2024-01-08 23:09:42 +0530
committersinanmohd <sinan@sinanmohd.com>2024-01-08 23:29:53 +0530
commitf8cea6f6c8a8ce35533d7fa978dbff8cd5427b7c (patch)
treeb87d5da18c6f86d3a931a88370f41421833e9814 /modules/userdata.nix
parent119d8d504f435b552e548a9130ae96a2a3721dff (diff)
modules/userdata: refactor
Diffstat (limited to 'modules/userdata.nix')
-rw-r--r--modules/userdata.nix39
1 files changed, 1 insertions, 38 deletions
diff --git a/modules/userdata.nix b/modules/userdata.nix
index 136d807..46c7377 100644
--- a/modules/userdata.nix
+++ b/modules/userdata.nix
@@ -1,26 +1,8 @@
-{ config, lib, pkgs, ... }:
+{ config, lib, ... }:
let
inherit (lib) mkOption types mdDoc;
cfg = config.userdata;
-
- defaultPackages = with pkgs; [
- bc
- unzip
- htop
- curl
- file
- dig
- mtr
- nnn
- ps_mem
- brightnessctl
- ];
- defaultPubKeys = [
- "ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIDCeMXhkjm9CabbA/1xdtP9bvFEm8pVXPk66NmI9/VvQ sinan@vex"
- "ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIL8LnyOuPmtKRqAZeHueNN4kfYvpRQVwCivSTq+SZvDU sinan@cez"
- ];
- defaultGroups = [ "wheel" ];
in
{
options.userdata = {
@@ -29,11 +11,6 @@ in
default = "sinan";
description = mdDoc "Owner's username";
};
- groups = mkOption {
- type = types.listOf types.str;
- default = [];
- description = mdDoc "Groups the owner should be in";
- };
domain = mkOption {
type = types.str;
default = "sinanmohd.com";
@@ -44,25 +21,11 @@ in
default = "sinan@firemail.cc";
description = mdDoc "Owner's email";
};
- packages = mkOption {
- type = types.listOf types.package;
- default = [];
- description = mdDoc "Packages in owner's environment";
- };
- pubKeys = mkOption {
- type = types.listOf types.str;
- description = mdDoc "Owner's public ssh keys";
- default = [];
- };
};
config.users.users.${cfg.user} = {
uid = 1000;
isNormalUser = true;
description = cfg.email;
-
- extraGroups = defaultGroups ++ cfg.groups;
- packages = defaultPackages ++ cfg.packages;
- openssh.authorizedKeys.keys = defaultPubKeys ++ cfg.pubKeys;
};
}