summaryrefslogtreecommitdiff
path: root/modules/wayland.nix
diff options
context:
space:
mode:
authorsinanmohd <sinan@sinanmohd.com>2023-08-29 12:42:16 +0530
committersinanmohd <sinan@sinanmohd.com>2023-08-29 14:52:02 +0530
commit2295504252272605189c968d977644f04afa3355 (patch)
tree37b928718e25e68d9dccf8beed384d74a072c3b3 /modules/wayland.nix
parent9d84efe93593f82c5108a06cd4a3500850e2ca21 (diff)
modules/seatd: init
Diffstat (limited to 'modules/wayland.nix')
-rw-r--r--modules/wayland.nix14
1 files changed, 8 insertions, 6 deletions
diff --git a/modules/wayland.nix b/modules/wayland.nix
index a06834c..4ae34e1 100644
--- a/modules/wayland.nix
+++ b/modules/wayland.nix
@@ -1,6 +1,8 @@
{ pkgs, ... }:
{
+ imports = [ ./seatd.nix ];
+
# pkgs
environment.systemPackages = with pkgs; [
dwl-sinan
@@ -47,9 +49,11 @@
};
# misc
- hardware.opengl.enable = true;
+ services = {
+ seatd.enable = true;
+ dbus.enable = true;
+ };
- services.dbus.enable = true;
programs = {
xwayland.enable = true;
gnupg.agent = {
@@ -66,8 +70,6 @@
};
};
- security = {
- polkit.enable = true;
- pam.services.swaylock.text = "auth include login";
- };
+ security.pam.services.swaylock.text = "auth include login";
+ hardware.opengl.enable = true;
}