summaryrefslogtreecommitdiff
path: root/modules/wayland.nix
diff options
context:
space:
mode:
authorsinanmohd <sinan@sinanmohd.com>2023-09-02 11:45:57 +0530
committersinanmohd <sinan@sinanmohd.com>2023-09-02 11:50:28 +0530
commite441dc43cf5c9707cf580c36805a5aaa66f33b3c (patch)
tree0b86984a3d818ede2c6c42bdb0c63e7e9246cbf1 /modules/wayland.nix
parent06d4452b1d18fd60b0f6adae50992418053f3971 (diff)
module/userdata: init
Diffstat (limited to 'modules/wayland.nix')
-rw-r--r--modules/wayland.nix6
1 files changed, 5 insertions, 1 deletions
diff --git a/modules/wayland.nix b/modules/wayland.nix
index 17b9279..7af2f51 100644
--- a/modules/wayland.nix
+++ b/modules/wayland.nix
@@ -1,5 +1,8 @@
{ config, pkgs, ... }:
+let
+ user = config.userdata.user;
+in
{
imports = [ ./seatd.nix ];
@@ -20,7 +23,7 @@
wob
wlr-randr
];
- users.users.${config.passthru.user}.packages = with pkgs; [
+ users.users.${user}.packages = with pkgs; [
zathura
mpv
imv
@@ -75,6 +78,7 @@
};
};
+ userdata.groups = [ "seat" ];
security.pam.services.swaylock.text = "auth include login";
hardware.opengl.enable = true;
}