summaryrefslogtreecommitdiff
path: root/os/cez/modules/sshfs.nix
diff options
context:
space:
mode:
authorsinanmohd <sinan@sinanmohd.com>2024-06-04 14:38:25 +0530
committersinanmohd <sinan@sinanmohd.com>2024-06-04 18:04:18 +0530
commit654fa9e430be421df30ee79e7ea5f4e40b39dddc (patch)
tree37d9bc759e3e1b3323e76d85d706123f3b799d88 /os/cez/modules/sshfs.nix
parent84073038e22d3201ac0176a94527c040bb153e9e (diff)
home, os: refactor
Diffstat (limited to 'os/cez/modules/sshfs.nix')
-rw-r--r--os/cez/modules/sshfs.nix27
1 files changed, 0 insertions, 27 deletions
diff --git a/os/cez/modules/sshfs.nix b/os/cez/modules/sshfs.nix
deleted file mode 100644
index 5fdbeaf..0000000
--- a/os/cez/modules/sshfs.nix
+++ /dev/null
@@ -1,27 +0,0 @@
-{ config, pkgs, ... }:
-
-let
- domain = config.global.userdata.domain;
- user = config.global.userdata.name;
- uid = config.users.users.${user}.uid;
- gid = config.users.groups.users.gid;
-in
-{
- sops.secrets."misc/sftp" = {};
- system.fsPackages = with pkgs; [ sshfs ];
-
- fileSystems."/media/kay" = {
- device = "sftp@${domain}:";
- fsType = "sshfs";
- options = [
- "allow_other" # for non-root access
- "uid=${toString uid}"
- "gid=${toString gid}"
- "_netdev" # this is a network fs
- "x-systemd.automount" # mount on demand
- "reconnect" # handle connection drops
- "ServerAliveInterval=15" # keep connections alive
- "IdentityFile=${config.sops.secrets."misc/sftp".path}"
- ];
- };
-}