summaryrefslogtreecommitdiff
path: root/os/kay/modules/postgresql.nix
diff options
context:
space:
mode:
authorsinanmohd <sinan@sinanmohd.com>2025-01-06 10:26:17 +0530
committersinanmohd <sinan@sinanmohd.com>2025-01-06 20:54:19 +0530
commit5c274e6214c321a8ba90d473e3500989d6e84ed1 (patch)
tree4465855aa6ae6423a0c853fa6896b80e4e18a0a9 /os/kay/modules/postgresql.nix
parentcf6f1cf7c1d9100da519db1c9977152d6f246ecb (diff)
kay/postgresql: init
Diffstat (limited to 'os/kay/modules/postgresql.nix')
-rw-r--r--os/kay/modules/postgresql.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/os/kay/modules/postgresql.nix b/os/kay/modules/postgresql.nix
new file mode 100644
index 0000000..6f4d126
--- /dev/null
+++ b/os/kay/modules/postgresql.nix
@@ -0,0 +1,17 @@
+{ config, lib, pkgs, ... }: {
+ services.postgresql = {
+ enable = true;
+ package = with pkgs; postgresql_15;
+ authentication = lib.mkForce ''
+ #type database DBuser origin-address auth-method
+ # unix socket
+ local all all trust
+ # ipv4
+ host all all 127.0.0.1/32 trust
+ # ipv6
+ host all all ::1/128 trust
+ '';
+
+ settings.log_timezone = config.time.timeZone;
+ };
+}