summaryrefslogtreecommitdiff
path: root/os/kay/modules/router.nix
diff options
context:
space:
mode:
authorsinanmohd <sinan@sinanmohd.com>2024-11-24 09:11:34 +0530
committersinanmohd <sinan@sinanmohd.com>2024-11-24 09:11:34 +0530
commit26960607983a7010b414d560a182f81a1829f91d (patch)
treeb3ec7d701e8b83282851e17cd5c0bbf0ceaff035 /os/kay/modules/router.nix
parent94553dd42bc84cc4a3d142a5d571609d820cce7e (diff)
kay/router: avoid using nat on gpon subnet
Diffstat (limited to 'os/kay/modules/router.nix')
-rw-r--r--os/kay/modules/router.nix10
1 files changed, 1 insertions, 9 deletions
diff --git a/os/kay/modules/router.nix b/os/kay/modules/router.nix
index 8bf7cde..daf4f63 100644
--- a/os/kay/modules/router.nix
+++ b/os/kay/modules/router.nix
@@ -2,8 +2,7 @@
wanInterface = "ppp0";
gponInterface = "enp3s0";
- gponHost = "192.168.38.2";
- gponSubnet = "192.168.38.0";
+ gponHost = "192.168.38.1";
gponPrefix = 24;
lanInterface = "enp8s0f3u1";
@@ -48,13 +47,6 @@ in {
iptables -t mangle -A FORWARD -p tcp --tcp-flags SYN,RST SYN \
-o ${wanInterface} \
-j TCPMSS --clamp-mss-to-pmtu
-
- iptables -t nat -I POSTROUTING 1 \
- -d ${gponSubnet}/${toString gponPrefix} \
- -j MASQUERADE
- iptables -t mangle -A FORWARD -p tcp --tcp-flags SYN,RST SYN \
- -d ${gponSubnet}/${toString gponPrefix} \
- -j TCPMSS --clamp-mss-to-pmtu
'';
};
};