summaryrefslogtreecommitdiff
path: root/os/pc/modules/getty.nix
diff options
context:
space:
mode:
authorsinanmohd <sinan@sinanmohd.com>2024-06-04 14:38:25 +0530
committersinanmohd <sinan@sinanmohd.com>2024-06-04 18:04:18 +0530
commit654fa9e430be421df30ee79e7ea5f4e40b39dddc (patch)
tree37d9bc759e3e1b3323e76d85d706123f3b799d88 /os/pc/modules/getty.nix
parent84073038e22d3201ac0176a94527c040bb153e9e (diff)
home, os: refactor
Diffstat (limited to 'os/pc/modules/getty.nix')
-rw-r--r--os/pc/modules/getty.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/os/pc/modules/getty.nix b/os/pc/modules/getty.nix
new file mode 100644
index 0000000..8c7f57e
--- /dev/null
+++ b/os/pc/modules/getty.nix
@@ -0,0 +1,15 @@
+{ config, ... }: let
+ user = config.global.userdata.name;
+in {
+ systemd.services."getty@".serviceConfig.TTYVTDisallocate = "no";
+
+ services.getty = {
+ loginOptions = "-f ${user}";
+ extraArgs = [
+ "--nonewline"
+ "--skip-login"
+ "--noclear"
+ "--noissue"
+ ];
+ };
+}