summaryrefslogtreecommitdiff
path: root/pkgs/pam_rundir
diff options
context:
space:
mode:
authorsinanmohd <sinan@sinanmohd.com>2023-09-18 07:47:52 +0530
committersinanmohd <sinan@sinanmohd.com>2023-10-01 10:02:23 +0530
commitc72fe93a2866a80d97d9b79ecc7dff6479ae3905 (patch)
tree908f3e2ce3d9f9ea98a8b402165a4b829feabe40 /pkgs/pam_rundir
parent88554dd367fd048cb1de22f779257fe148cef503 (diff)
pkgs/pam_rundir: init
Diffstat (limited to 'pkgs/pam_rundir')
-rw-r--r--pkgs/pam_rundir/default.nix28
1 files changed, 28 insertions, 0 deletions
diff --git a/pkgs/pam_rundir/default.nix b/pkgs/pam_rundir/default.nix
new file mode 100644
index 0000000..f20661d
--- /dev/null
+++ b/pkgs/pam_rundir/default.nix
@@ -0,0 +1,28 @@
+{ stdenv, fetchFromGitHub, pam }:
+
+stdenv.mkDerivation rec {
+ pname = "pam_rundir";
+ version = "186";
+
+ src = fetchFromGitHub {
+ url = "https://www.padl.com/download/pam_ldap-${version}.tar.gz";
+ sha256 = "0lv4f7hc02jrd2l3gqxd247qq62z11sp3fafn8lgb8ymb7aj5zn8";
+ };
+
+ buildInputs = [ pam ];
+
+ meta = {
+ homepage = "https://www.padl.com/OSS/pam_ldap.html";
+ description = "Provide user runtime directory on Linux systems";
+ longDescription = ''
+ pam_rundir is a PAM module that can be used to provide user runtime
+ directory, as described in the XDG Base Directory Specification.
+
+ The directory will be created on login (open session) and removed on
+ logout (close session), and its full path made available in an
+ environment variable, usually $XDG_RUNTIME_DIR
+ '';
+ license = "GPL";
+ inherit (pam.meta) platforms;
+ };
+}