summaryrefslogtreecommitdiff
path: root/userdata.nix
diff options
context:
space:
mode:
authorsinanmohd <sinan@sinanmohd.com>2024-06-03 18:28:35 +0530
committersinanmohd <sinan@sinanmohd.com>2024-06-03 18:39:43 +0530
commit279ff6251173e161cc50d8ae03cb3cd2e90a61a4 (patch)
tree971260447397a872be4b051b55864b482acc4a57 /userdata.nix
parent4311eaf183976752acdf5624ea68516cac6f0d94 (diff)
global: init
global contains shared data between home-manager and nixos modules. they're just structured data, it's doesn't contain any module functionally in the normal sense, an example is preferred monospace font or user's mail id `config.global.userdata.email`
Diffstat (limited to 'userdata.nix')
-rw-r--r--userdata.nix30
1 files changed, 0 insertions, 30 deletions
diff --git a/userdata.nix b/userdata.nix
deleted file mode 100644
index 564f1f0..0000000
--- a/userdata.nix
+++ /dev/null
@@ -1,30 +0,0 @@
-{ config, lib, ... }:
-
-let
- inherit (lib) mkOption types;
- cfg = config.userdata;
-in
-{
- options.userdata = {
- name = mkOption {
- type = types.str;
- default = "sinan";
- description = "Owner's username";
- };
- nameFq = mkOption {
- type = types.str;
- default = "sinanmohd";
- description = "Owner's fully qualified username";
- };
- domain = mkOption {
- type = types.str;
- default = "sinanmohd.com";
- description = "Owner's domain";
- };
- email = mkOption {
- type = types.str;
- default = "${cfg.name}@${cfg.domain}";
- description = "Owner's email";
- };
- };
-}