summaryrefslogtreecommitdiff
path: root/userdata.nix
diff options
context:
space:
mode:
authorsinanmohd <sinan@sinanmohd.com>2024-03-08 17:42:39 +0530
committersinanmohd <sinan@sinanmohd.com>2024-03-08 19:19:44 +0530
commit3ea06b0f61da129b6cd6a4f4d8648f051c30a74c (patch)
tree3143ab50492a892f785b2db71ea791b6abd46e19 /userdata.nix
parent74cf6b4fc52e6662c95163f17786ff0599889e06 (diff)
home-manager: init
Diffstat (limited to 'userdata.nix')
-rw-r--r--userdata.nix30
1 files changed, 30 insertions, 0 deletions
diff --git a/userdata.nix b/userdata.nix
new file mode 100644
index 0000000..ebcd1db
--- /dev/null
+++ b/userdata.nix
@@ -0,0 +1,30 @@
+{ config, lib, ... }:
+
+let
+ inherit (lib) mkOption types;
+ cfg = config.userdata;
+in
+{
+ options.userdata = {
+ user = mkOption {
+ type = types.str;
+ default = "sinan";
+ description = "Owner's username";
+ };
+ userFq = mkOption {
+ type = types.str;
+ default = "sinanmohd";
+ description = "Owner's fully qualified username";
+ };
+ domain = mkOption {
+ type = types.str;
+ default = "sinanmohd.com";
+ description = "Owner's domain";
+ };
+ email = mkOption {
+ type = types.str;
+ default = "${cfg.user}@${cfg.domain}";
+ description = "Owner's email";
+ };
+ };
+}