summaryrefslogtreecommitdiff
path: root/common.nix
diff options
context:
space:
mode:
Diffstat (limited to 'common.nix')
-rw-r--r--common.nix6
1 files changed, 4 insertions, 2 deletions
diff --git a/common.nix b/common.nix
index f550d7c..5483f63 100644
--- a/common.nix
+++ b/common.nix
@@ -94,9 +94,11 @@ in
# programs
programs.bash.promptInit = ''
- PROMPT_COLOR="1;31m"
- [ "$UID" -ne 0 ] &&
+ if [ "$UID" -ne 0 ]; then
PROMPT_COLOR="1;32m"
+ else
+ PROMPT_COLOR="1;31m"
+ fi
PS1="\[\033[$PROMPT_COLOR\][\[\e]0;\u@\h: \w\a\]\u@\h:\w]\\$\[\033[0m\] "
'';