diff options
Diffstat (limited to 'common.nix')
-rw-r--r-- | common.nix | 27 |
1 files changed, 0 insertions, 27 deletions
@@ -1,10 +1,6 @@ { config, pkgs, ... }: let - user = config.userdata.user; - groups = config.userdata.groups; - description = config.userdata.email; - pubKeys = config.userdata.pubKeys; host = config.networking.hostName; in { @@ -29,29 +25,6 @@ in }; }; - # users - users.users.${user} = { - inherit description; - isNormalUser = true; - uid = 1000; - extraGroups = [ - "wheel" - ] ++ groups; - packages = with pkgs; [ - yt-dlp - geoipWithDatabase - dig - nnn - ffmpeg - rtorrent - ps_mem - brightnessctl - neofetch - (pass.withExtensions (exts: [ exts.pass-otp ])) - ]; - openssh.authorizedKeys.keys = pubKeys; - }; - # system environment = { binsh = "${pkgs.dash}/bin/dash"; |