summaryrefslogtreecommitdiff
path: root/features/kaysshfs.nix
diff options
context:
space:
mode:
Diffstat (limited to 'features/kaysshfs.nix')
-rw-r--r--features/kaysshfs.nix9
1 files changed, 5 insertions, 4 deletions
diff --git a/features/kaysshfs.nix b/features/kaysshfs.nix
index ec6a118..83cb68e 100644
--- a/features/kaysshfs.nix
+++ b/features/kaysshfs.nix
@@ -1,13 +1,14 @@
{ config, pkgs, ... }:
{
- system.fsPackages = [ pkgs.sshfs ];
+ system.fsPackages = with pkgs; [
+ sshfs
+ ];
fileSystems."/mnt/kay" = {
device = "sinansftp@sinanmohd.com:";
fsType = "sshfs";
- options =
- [ # Filesystem options
+ options = [
"allow_other" # for non-root access
"_netdev" # this is a network fs
"x-systemd.automount" # mount on demand
@@ -16,6 +17,6 @@
"reconnect" # handle connection drops
"ServerAliveInterval=15" # keep connections alive
"IdentityFile=/var/secrets/kaysftp-key"
- ];
+ ];
};
}