summaryrefslogtreecommitdiff
path: root/features/wayland.nix
diff options
context:
space:
mode:
Diffstat (limited to 'features/wayland.nix')
-rw-r--r--features/wayland.nix23
1 files changed, 0 insertions, 23 deletions
diff --git a/features/wayland.nix b/features/wayland.nix
index 20e070b..c521eb5 100644
--- a/features/wayland.nix
+++ b/features/wayland.nix
@@ -1,24 +1,5 @@
{ config, pkgs, ... }:
-let
- # gtk theming: https://github.com/swaywm/sway/wiki/GTK-3-settings-on-Wayland
- # for gsettings to work, we need to tell it where the schemas are
- # using the XDG_DATA_DIR environment variable
- configure-gtk = pkgs.writeTextFile {
- name = "configure-gtk";
- destination = "/bin/configure-gtk";
- executable = true;
- text = let
- schema = pkgs.gsettings-desktop-schemas;
- datadir = "${schema}/share/gsettings-schemas/${schema.name}";
- in
- ''
- export XDG_DATA_DIRS=${datadir}:$XDG_DATA_DIRS
- gnome_schema=org.gnome.desktop.interface
- gsettings set $gnome_schema gtk-theme 'Dracula'
- '';
- };
-in
{
# pkgs
environment.systemPackages = with pkgs; [
@@ -47,9 +28,6 @@ in
wlr-randr
tor-browser-bundle-bin
wtype
- configure-gtk
- dracula-theme # gtk theme
- glib # gsettings
];
# font
@@ -71,7 +49,6 @@ in
services.dbus.enable = true;
programs = {
- dconf.enable = true;
xwayland.enable = true;
gnupg.agent = {
enable = true;