summaryrefslogtreecommitdiff
path: root/features/wayland.nix
diff options
context:
space:
mode:
Diffstat (limited to 'features/wayland.nix')
-rw-r--r--features/wayland.nix72
1 files changed, 0 insertions, 72 deletions
diff --git a/features/wayland.nix b/features/wayland.nix
deleted file mode 100644
index 1eb1289..0000000
--- a/features/wayland.nix
+++ /dev/null
@@ -1,72 +0,0 @@
-{ config, pkgs, ... }:
-
-{
- # pkgs
- environment.systemPackages = with pkgs; [
- dwl-sinan
- zathura
- pinentry-gnome
- mpv
- qemu
- OVMFFull
- element-desktop
- swaylock
- swayidle
- swaybg
- foot
- grim
- slurp
- wl-clipboard
- wmenu-sinan
- mako
- wayland
- xdg-utils
- imv
- libnotify
- wob
- wlr-randr
- tor-browser-bundle-bin
- wtype
- ];
-
- # font
- fonts = {
- packages = with pkgs; [
- terminus-nerdfont
- dm-sans
- ];
- enableDefaultPackages = true;
- fontconfig = {
- hinting.style = "full";
- defaultFonts = {
- monospace = [ "Terminess Nerd Font" ];
- serif = [ "DeepMind Sans" ];
- sansSerif = [ "DeepMind Sans" ];
- };
- };
- };
-
- # misc
- hardware.opengl.enable = true;
-
- services.dbus.enable = true;
- programs = {
- xwayland.enable = true;
- gnupg.agent = {
- enable = true;
- pinentryFlavor = "gnome3";
- };
- firefox = {
- enable = true;
- preferences = {
- "media.ffmpeg.vaapi.enabled" = true;
- "gfx.webrender.all" = true;
- };
- };
- };
-
- security = {
- polkit.enable = true;
- pam.services.swaylock.text = "auth include login";
- };
-}