summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix21
1 files changed, 17 insertions, 4 deletions
diff --git a/flake.nix b/flake.nix
index 93713c0..3c47785 100644
--- a/flake.nix
+++ b/flake.nix
@@ -1,16 +1,29 @@
{
description = "reproducible nixos configuration with flakes";
- inputs.nixpkgs.url = "github:NixOs/nixpkgs/nixos-unstable";
- outputs = { self, nixpkgs }: {
+ inputs = {
+ nixpkgs.url = "github:NixOs/nixpkgs/nixos-unstable";
+ sops-nix = {
+ url = "github:Mic92/sops-nix";
+ inputs.nixpkgs.follows = "nixpkgs";
+ };
+ };
+
+ outputs = { self, nixpkgs, sops-nix }: {
nixosConfigurations = {
cez = nixpkgs.lib.nixosSystem {
system = "x86_64-linux";
- modules = [ ./hosts/cez/configuration.nix ];
+ modules = [
+ ./hosts/cez/configuration.nix
+ sops-nix.nixosModules.sops
+ ];
};
kay = nixpkgs.lib.nixosSystem {
system = "x86_64-linux";
- modules = [ ./hosts/kay/configuration.nix ];
+ modules = [
+ ./hosts/kay/configuration.nix
+ sops-nix.nixosModules.sops
+ ];
};
};
};