summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix7
1 files changed, 5 insertions, 2 deletions
diff --git a/flake.nix b/flake.nix
index 3e5f310..d8f6d7a 100644
--- a/flake.nix
+++ b/flake.nix
@@ -21,10 +21,13 @@
makeNixos = host: system: lib.nixosSystem {
inherit system;
modules = [
+ {
+ networking.hostName = host;
+ nix.nixPath = [ "nixpkgs=${nixpkgs}" ];
+ }
+
./userdata.nix
- { networking.hostName = host; }
./nixos/${host}/configuration.nix
-
sops-nix.nixosModules.sops
];
};