summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..93713c0
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,17 @@
+{
+ description = "reproducible nixos configuration with flakes";
+ inputs.nixpkgs.url = "github:NixOs/nixpkgs/nixos-unstable";
+
+ outputs = { self, nixpkgs }: {
+ nixosConfigurations = {
+ cez = nixpkgs.lib.nixosSystem {
+ system = "x86_64-linux";
+ modules = [ ./hosts/cez/configuration.nix ];
+ };
+ kay = nixpkgs.lib.nixosSystem {
+ system = "x86_64-linux";
+ modules = [ ./hosts/kay/configuration.nix ];
+ };
+ };
+ };
+}