summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix14
1 files changed, 8 insertions, 6 deletions
diff --git a/flake.nix b/flake.nix
index f6d8161..70153b4 100644
--- a/flake.nix
+++ b/flake.nix
@@ -26,18 +26,20 @@
nix.nixPath = [ "nixpkgs=${nixpkgs}" ];
}
- ./global
+ ./global/common
./os/${host}/configuration.nix
sops-nix.nixosModules.sops
- ];
+ ] ++ lib.optional (builtins.pathExists ./global/${host})
+ ./global/${host};
};
- makeHome = useType: system: home-manager.lib.homeManagerConfiguration {
+ makeHome = host: system: home-manager.lib.homeManagerConfiguration {
pkgs = nixpkgs.legacyPackages.${system};
modules = [
- ./global
- ./home/${useType}/home.nix
- ];
+ ./global/common
+ ./home/${host}/home.nix
+ ] ++ lib.optional (builtins.pathExists ./global/${host})
+ ./global/${host};
};
in
{