summaryrefslogtreecommitdiff
path: root/global/common/modules/font.nix
diff options
context:
space:
mode:
Diffstat (limited to 'global/common/modules/font.nix')
-rw-r--r--global/common/modules/font.nix36
1 files changed, 36 insertions, 0 deletions
diff --git a/global/common/modules/font.nix b/global/common/modules/font.nix
new file mode 100644
index 0000000..cf0ea61
--- /dev/null
+++ b/global/common/modules/font.nix
@@ -0,0 +1,36 @@
+{ pkgs, lib, ... }: let
+ name = {
+ type = lib.types.str;
+ example = "Terminess Nerd Font";
+ };
+ size = {
+ type = with lib.types; nullOr int;
+ default = null;
+ };
+ packages = {
+ type = with lib.types; listOf path;
+ example = "[ pkgs.terminus-nerdfont ]";
+ };
+in {
+ options.global.font = {
+ sans = {
+ size = lib.mkOption size;
+ name = lib.mkOption (name // {
+ default = "DeepMind Sans";
+ });
+ packages = lib.mkOption (packages // {
+ default = [ pkgs.dm-sans ];
+ });
+ };
+
+ monospace = {
+ size = lib.mkOption size;
+ name = lib.mkOption (name // {
+ default = "Terminess Nerd Font";
+ });
+ packages = lib.mkOption (packages // {
+ default = [ pkgs.terminus-nerdfont ];
+ });
+ };
+ };
+}